Fork me on GitHub

Orillacart with Multilingual site



Home Forums General support Orillacart with Multilingual site

Tagged: 

This topic contains 8 replies, has 3 voices, and was last updated by  engladlef 1 week, 5 days ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #6924

    pappszaby
    Participant

    Dear Support,

    I would like to use Orillacart for a multilingual site and I have already made some basic configuration however the pages like site/hu/shop/cart/ or site/en/shop/cart/; site/hu/shop/account/ or site/en/shop/account/ does not work.

    Due to the multilingual site I’m being automatically redirected to the above sites 🙁

    Do you have any workarround for this. If you wish I can send you the site

    Thank you

    #6925

    pappszaby
    Participant

    HI,

    Just in case somebody else is running into the same I have found the problem.

    I’m using Polylang so at the Settings/languages/Settings: yourwebsite.com/wp-admin/options-general.php?page=mlang&tab=settings you need to make sure that URL modifications is set to

    The language is set from content
    Posts, pages, categories and tags urls are not modified.

    #6926

    pappszaby
    Participant

    Hi,

    I have translated the whole widget into Hongarian langage useing poedit however the email (order) that is bening sent out to the customer is not translated. Where can I transate the email?

    #6927

    pappszaby
    Participant

    Sorry for the typo Hungarian

    #6928

    admin1
    Keymaster

    All email notification are included in the language file.
    language file: \com_shop\languages\com_shop.pot

    If you need to review or edit the email notifications: \com_shop\front\views\mail\templates

    Best Regards

    #6929

    pappszaby
    Participant

    Hmm… I will review again my translation as far as I have checked in po editor I translated everything. and saved it as com_shop-hu_HU.mo.

    #6931

    pappszaby
    Participant

    I have reviewed the translation and it looks okay everything is translated. I have tested again and even though the language used on site is Hungarian and the component is using the hangarian language during the order the email sent out is in English.

    #6932

    pappszaby
    Participant

    Hi, I had to play around with Lingotec as the solution is again with the multilingual plugin.

    The final solution was to set it the way described below. This is the ONLY option that works correctly.

    You need to make sure that these are selected:

    1. The language is set from the directory name in pretty permalinks

    Example: http://yoursite.com/en/my-post/

    2. Hide URL language information for default language

    3.  Remove /language/ in pretty permalink

    Regards
    Szabolcs

    By the way is a great plugin!!!

    • This reply was modified 1 year, 9 months ago by  pappszaby.
    #7067

    engladlef
    Participant

    а где вы взяли эту инфу[url=http://tr.educationinuk.ru/],[/url]

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.